BestNotes Status - Intermittent Performance Issues - EPCS IDP (Experian/ID.me) – Incident details

Intermittent Performance Issues - EPCS IDP (Experian/ID.me)

Resolved
Degraded performance
Started 5 months agoLasted about 5 hours

Affected

DrFirst ePrescribe (Classic edition)

Operational from 10:05 PM to 10:05 PM, Degraded performance from 10:05 PM to 3:15 AM

DrFirst → Third-Party Vendor Services → EPCS IDP (Experian/ID.me)

Operational from 10:05 PM to 10:05 PM, Degraded performance from 10:05 PM to 3:15 AM

Updates
  • Resolved
    UTC
    Resolved

    This incident has been resolved.

  • Identified
    UTC
    Identified

    The issue has been identified and a fix is being implemented.

  • Update
    UTC
    Update

    We are continuing to investigate this issue.

  • Investigating
    UTC
    Investigating

    IDP is currently experiencing an issue, which may affect your ability to authenticate or access services through the IDP. We are working with our 3rd Party vendor to resolve this as quickly as possible